Error with Installing Service Provider Register

Feb 18, 2009 at 6:27 PM
I am trying to install HCE and am at the step of installing the Service Provider Register.  Following the Deployment guide, I launch the installation file and accept the defaults but the installation fails with the error: "The system cannot find the specified path" on both the install and the rollback.

The application event (install) error log is as follows:

Event Type:    Error
Event Source:    MsiInstaller
Event Category:    None
Event ID:    11001
Date:        2/18/2009
Time:        1:22:46 PM
User:        ECET\Administrator
Computer:    CHEF
The description for Event ID ( 11001 ) in Source ( MsiInstaller ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Product: Microsoft Connection Engine 2.1.1 Service Provider Register -- Error 1001. An exception occurred during the Rollback phase of the installation. This exception will be ignored and the rollback will continue. However, the machine might not fully revert to its initial state after the rollback is complete. --> The system cannot find the path specified.
, (NULL), (NULL), (NULL).
0000: 7b 30 33 42 44 38 31 42   {03BD81B
0008: 36 2d 34 38 36 41 2d 34   6-486A-4
0010: 41 33 43 2d 42 31 46 39   A3C-B1F9
0018: 2d 35 36 39 44 32 41 32   -569D2A2
0020: 35 42 30 34 39 7d         5B049} 

I have ensured the sa user is enabled and password configured correctly.  I have also tried installing to multiple locations and browsing to the necessary path, but it still doesn't work.  PLEASE HELP.